summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGerald (Jerry) Carter <jerry@samba.org>2007-10-19 08:14:12 -0500
committerJeremy Allison <jra@samba.org>2007-10-19 13:09:26 -0700
commit80b7bcb5fbc98964014b5c8082a626aef24c5feb (patch)
treea9dc3c8114c9719140d8f83b01de5c6795b8684a /source3/configure.in
parent61c4666a897fc85b0eb41e60dcbeb78272bfe5cf (diff)
downloadsamba-80b7bcb5fbc98964014b5c8082a626aef24c5feb.tar.gz
samba-80b7bcb5fbc98964014b5c8082a626aef24c5feb.tar.bz2
samba-80b7bcb5fbc98964014b5c8082a626aef24c5feb.zip
Add test for "struct in6_addr" to the HAVE_IPV6 configure test.
Also make use of "if defined(HAVE_IPV6)" rather than testing for AF_INET6 since this is not sufficient on HP-UX 11.11 to ensure a working IPv6 implementation. (This used to be commit 620785df4e57b72471ff0315e22e0d2f28a2b1a5)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 5d236237a1..a96e2d91f6 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3038,6 +3038,7 @@ AC_TRY_COMPILE([
[
struct sockaddr_storage sa_store;
struct addrinfo *ai = NULL;
+struct in6_addr in6addr;
int s = socket(AF_INET6, SOCK_STREAM, 0);
int ret = getaddrinfo(NULL, NULL, NULL, &ai);
if (ret != 0) {