summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGuenther Deschner <gd@samba.org>2007-10-11 15:18:50 +0200
committerGuenther Deschner <gd@samba.org>2007-10-11 15:18:50 +0200
commit89d33395e31a7ccb6b091e4a99a30d12e3367238 (patch)
treef2ec7c4ddbf9134ecae18e27bf792b90da372663 /source3/configure.in
parent6b441e9e74b11bee4b661eaa17682d6351c264ff (diff)
parentedfcfefa37bf948c990e7ad3a1aea1dd4c3cea09 (diff)
downloadsamba-89d33395e31a7ccb6b091e4a99a30d12e3367238.tar.gz
samba-89d33395e31a7ccb6b091e4a99a30d12e3367238.tar.bz2
samba-89d33395e31a7ccb6b091e4a99a30d12e3367238.zip
Merge commit 'origin/v3-2-test' into my_branch
(This used to be commit fbe5edec375c99421d19af086c4f597e70c963b8)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in17
1 files changed, 14 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index a5f817ba68..bcb973a1d0 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -15,9 +15,20 @@ esac
SMB_VERSION_STRING=`cat $srcdir/include/version.h | grep 'SAMBA_VERSION_OFFICIAL_STRING' | cut -d '"' -f2`
echo "SAMBA VERSION: ${SMB_VERSION_STRING}"
-SAMBA_VERSION_SVN_REVISION=`cat $srcdir/include/version.h | grep 'SAMBA_VERSION_SVN_REVISION' | cut -d ' ' -f3-`
-if test -n "${SAMBA_VERSION_SVN_REVISION}";then
- echo "BUILD REVISION: ${SAMBA_VERSION_SVN_REVISION}"
+SAMBA_VERSION_GIT_COMMIT_FULLREV=`cat $srcdir/include/version.h | grep 'SAMBA_VERSION_GIT_COMMIT_FULLREV' | cut -d ' ' -f3- | cut -d '"' -f2`
+if test -n "${SAMBA_VERSION_GIT_COMMIT_FULLREV}";then
+ echo "BUILD COMMIT REVISION: ${SAMBA_VERSION_GIT_COMMIT_FULLREV}"
+fi
+SAMBA_VERSION_GIT_COMMIT_DATE=`cat $srcdir/include/version.h | grep 'SAMBA_VERSION_GIT_COMMIT_DATE' | cut -d ' ' -f3-`
+if test -n "${SAMBA_VERSION_GIT_COMMIT_DATE}";then
+ echo "BUILD COMMIT DATE: ${SAMBA_VERSION_GIT_COMMIT_DATE}"
+fi
+SAMBA_VERSION_GIT_COMMIT_TIME=`cat $srcdir/include/version.h | grep 'SAMBA_VERSION_GIT_COMMIT_TIME' | cut -d ' ' -f3-`
+if test -n "${SAMBA_VERSION_GIT_COMMIT_TIME}";then
+ echo "BUILD COMMIT TIME: ${SAMBA_VERSION_GIT_COMMIT_TIME}"
+
+ # just to keep the build-farm gui happy for now...
+ echo "BUILD REVISION: ${SAMBA_VERSION_GIT_COMMIT_TIME}"
fi
AC_LIBREPLACE_LOCATION_CHECKS