summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorStefan Metzmacher <metze@samba.org>2007-10-11 12:27:38 +0200
committerStefan Metzmacher <metze@samba.org>2007-10-11 12:27:38 +0200
commitedfcfefa37bf948c990e7ad3a1aea1dd4c3cea09 (patch)
tree24dd0a028aba46af8a254aea29f8e1c2473f1ab9 /source3/configure.in
parentad8aacfbf1a7981c4654a2f603c95904685f6895 (diff)
downloadsamba-edfcfefa37bf948c990e7ad3a1aea1dd4c3cea09.tar.gz
samba-edfcfefa37bf948c990e7ad3a1aea1dd4c3cea09.tar.bz2
samba-edfcfefa37bf948c990e7ad3a1aea1dd4c3cea09.zip
prepare the mkversion.sh infrastructure for git branches in the build-farm
metze (This used to be commit 1bf4c7fb2012a81e0b4e3d601a4df42d1113f5ef)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in17
1 files changed, 14 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index db4e068524..6fb46874e9 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -15,9 +15,20 @@ esac
SMB_VERSION_STRING=`cat $srcdir/include/version.h | grep 'SAMBA_VERSION_OFFICIAL_STRING' | cut -d '"' -f2`
echo "SAMBA VERSION: ${SMB_VERSION_STRING}"
-SAMBA_VERSION_SVN_REVISION=`cat $srcdir/include/version.h | grep 'SAMBA_VERSION_SVN_REVISION' | cut -d ' ' -f3-`
-if test -n "${SAMBA_VERSION_SVN_REVISION}";then
- echo "BUILD REVISION: ${SAMBA_VERSION_SVN_REVISION}"
+SAMBA_VERSION_GIT_COMMIT_FULLREV=`cat $srcdir/include/version.h | grep 'SAMBA_VERSION_GIT_COMMIT_FULLREV' | cut -d ' ' -f3- | cut -d '"' -f2`
+if test -n "${SAMBA_VERSION_GIT_COMMIT_FULLREV}";then
+ echo "BUILD COMMIT REVISION: ${SAMBA_VERSION_GIT_COMMIT_FULLREV}"
+fi
+SAMBA_VERSION_GIT_COMMIT_DATE=`cat $srcdir/include/version.h | grep 'SAMBA_VERSION_GIT_COMMIT_DATE' | cut -d ' ' -f3-`
+if test -n "${SAMBA_VERSION_GIT_COMMIT_DATE}";then
+ echo "BUILD COMMIT DATE: ${SAMBA_VERSION_GIT_COMMIT_DATE}"
+fi
+SAMBA_VERSION_GIT_COMMIT_TIME=`cat $srcdir/include/version.h | grep 'SAMBA_VERSION_GIT_COMMIT_TIME' | cut -d ' ' -f3-`
+if test -n "${SAMBA_VERSION_GIT_COMMIT_TIME}";then
+ echo "BUILD COMMIT TIME: ${SAMBA_VERSION_GIT_COMMIT_TIME}"
+
+ # just to keep the build-farm gui happy for now...
+ echo "BUILD REVISION: ${SAMBA_VERSION_GIT_COMMIT_TIME}"
fi
AC_LIBREPLACE_LOCATION_CHECKS