summaryrefslogtreecommitdiff
path: root/source4/build/pidl/Makefile.PL
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2005-07-09 15:32:08 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 13:19:27 -0500
commitfa1445f4bc962efb3e639d3a4e345b1db14155b7 (patch)
tree8799d04bc9ec022569fedd636e899bcc29a57935 /source4/build/pidl/Makefile.PL
parentc222331d6d3785075bb0c961315aae9380101e47 (diff)
downloadsamba-fa1445f4bc962efb3e639d3a4e345b1db14155b7.tar.gz
samba-fa1445f4bc962efb3e639d3a4e345b1db14155b7.tar.bz2
samba-fa1445f4bc962efb3e639d3a4e345b1db14155b7.zip
r8264: - Use standard perl package structure for pidl.
- Only "use" pidl modules in the main executable when necessary Try 'make install' in build/pidl to install the package (should work stand-alone). (This used to be commit c620095692122a65ae1c5d85ca20468d4de93c54)
Diffstat (limited to 'source4/build/pidl/Makefile.PL')
-rwxr-xr-xsource4/build/pidl/Makefile.PL15
1 files changed, 15 insertions, 0 deletions
diff --git a/source4/build/pidl/Makefile.PL b/source4/build/pidl/Makefile.PL
new file mode 100755
index 0000000000..1c08f9f9b8
--- /dev/null
+++ b/source4/build/pidl/Makefile.PL
@@ -0,0 +1,15 @@
+use ExtUtils::MakeMaker;
+WriteMakefile(
+ 'NAME' => 'Parse::Pidl',
+ 'VERSION_FROM' => 'Parse/Pidl.pm',
+ 'EXE_FILES' => [ 'pidl' ],
+ 'PMLIBDIRS' => [ 'Parse' ],
+ 'C' => [],
+);
+
+sub MY::postamble {
+<<'EOT';
+Parse/Pidl/IDL.pm :: idl.yp
+ yapp -s -m 'Parse::Pidl::IDL' -o 'Parse/Pidl/IDL.pm' idl.yp
+EOT
+}