summaryrefslogtreecommitdiff
path: root/source4/configure.ac
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2008-01-23 15:09:55 +1100
committerAndrew Bartlett <abartlet@samba.org>2008-01-23 15:09:55 +1100
commit56a611b12618ef0224a7a8a12883e0ab8340962d (patch)
treed7bdef53981d1131bee032bfd7b1d68b597c6fe2 /source4/configure.ac
parent2eab4abf25453a1849adb28d65869c16b2479f57 (diff)
parent37325c4c1324d6b768bc8f4449a954550333e34d (diff)
downloadsamba-56a611b12618ef0224a7a8a12883e0ab8340962d.tar.gz
samba-56a611b12618ef0224a7a8a12883e0ab8340962d.tar.bz2
samba-56a611b12618ef0224a7a8a12883e0ab8340962d.zip
Merge branch 'v4-0-test' of git://git.samba.org/samba into 4-0-local
(This used to be commit f82eec69f1846aa46e4afe595d956cfd2256c335)
Diffstat (limited to 'source4/configure.ac')
-rw-r--r--source4/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/source4/configure.ac b/source4/configure.ac
index 164a21e823..23fc1023ad 100644
--- a/source4/configure.ac
+++ b/source4/configure.ac
@@ -27,11 +27,20 @@ m4_include(lib/charset/config.m4)
m4_include(lib/socket/config.m4)
m4_include(nsswitch/nsstest.m4)
+AC_OUTPUT(lib/registry/registry.pc)
+AC_OUTPUT(librpc/dcerpc.pc)
+AC_OUTPUT(librpc/ndr.pc)
+AC_OUTPUT(torture/torture.pc)
+AC_OUTPUT(auth/gensec/gensec.pc)
+AC_OUTPUT(param/samba-config.pc)
+AC_OUTPUT(librpc/dcerpc_samr.pc)
+
SMB_EXT_LIB_FROM_PKGCONFIG(LIBTALLOC, talloc >= 1.1.0,
[],
[
m4_include(lib/talloc/libtalloc.m4)
SMB_INCLUDE_MK(lib/talloc/config.mk)
+ AC_OUTPUT(lib/talloc/talloc.pc)
]
)
@@ -40,6 +49,7 @@ SMB_EXT_LIB_FROM_PKGCONFIG(LIBTDB, tdb >= 1.1.0,
[
m4_include(lib/tdb/libtdb.m4)
SMB_INCLUDE_MK(lib/tdb/config.mk)
+ AC_OUTPUT(lib/tdb/tdb.pc)
]
)
@@ -50,6 +60,7 @@ SMB_EXT_LIB_FROM_PKGCONFIG(LIBLDB, ldb >= 0.9.1,
SMB_INCLUDE_MK(lib/ldb/ldb_ildap/config.mk)
SMB_INCLUDE_MK(lib/ldb/tools/config.mk)
SMB_SUBSYSTEM(ldb_map, [], [LIBLDB])
+ AC_OUTPUT(lib/ldb/ldb.pc)
define_ldb_modulesdir=no
],
[