summaryrefslogtreecommitdiff
path: root/source4/configure.in
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2005-07-28 11:51:37 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 13:30:09 -0500
commit930e624d816a175d5ca4448e6ed40bc7dd8ec5b7 (patch)
treecefd60a954d828902c8fde6a6e8a69954e0baa63 /source4/configure.in
parentd0496a4ee626f829f1b5032122d2daf53e0bd2e2 (diff)
downloadsamba-930e624d816a175d5ca4448e6ed40bc7dd8ec5b7.tar.gz
samba-930e624d816a175d5ca4448e6ed40bc7dd8ec5b7.tar.bz2
samba-930e624d816a175d5ca4448e6ed40bc7dd8ec5b7.zip
r8826: Make configure generate config.mk files (with the external libraries
that were found) and a config.pm file (with all substitution variables) (This used to be commit 52bb1374bbcfc9b9a6d098687bafe9021a1ee858)
Diffstat (limited to 'source4/configure.in')
-rw-r--r--source4/configure.in26
1 files changed, 25 insertions, 1 deletions
diff --git a/source4/configure.in b/source4/configure.in
index 51589e9fe8..f678d9c7e8 100644
--- a/source4/configure.in
+++ b/source4/configure.in
@@ -5,6 +5,7 @@ dnl disabled 2.53 requirement - we do work with 2.52 on suse 7.3 for example
dnl AC_PREREQ(2.53)
AC_INIT([samba],[],[samba-technical@samba.org])
+
AC_CONFIG_SRCDIR([include/includes.h])
AC_CONFIG_HEADER(include/config.h)
@@ -85,4 +86,27 @@ dnl Remove -I/usr/include/? from CFLAGS and CPPFLAGS
CFLAGS_REMOVE_USR_INCLUDE(CFLAGS)
CFLAGS_REMOVE_USR_INCLUDE(CPPFLAGS)
-SMB_AC_OUTPUT(Makefile)
+echo "configure: creating config.pl"
+cat >config.pm<<CEOF
+# config.pm - Autogenerate by configure. DO NOT EDIT!
+
+package config;
+use strict;
+
+use vars qw(%enabled AC_FOREACH([AC_Var], m4_defn([_AC_SUBST_VARS]), [\$AC_Var ]));
+
+AC_FOREACH([AC_Var], m4_defn([_AC_SUBST_VARS]), [
+\$AC_Var = "$AC_Var";])
+
+$SMB_INFO_ENABLES
+CEOF
+
+echo "configure: creating config.mk"
+cat >config.mk<<CEOF
+# config.mk - Autogenerated by configure, DO NOT EDIT!
+$SMB_INFO_EXT_LIBS
+$SMB_INFO_SUBSYSTEMS
+$SMB_INFO_LIBRARIES
+CEOF
+
+AC_OUTPUT(Makefile,,[$PERL -Ibuild build/smb_build/main.pl])