summaryrefslogtreecommitdiff
path: root/source4/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2004-01-22 10:22:03 +0000
committerAndrew Bartlett <abartlet@samba.org>2004-01-22 10:22:03 +0000
commit0ea253d728ef404ad9ef3e13e92b59d8890713aa (patch)
tree92c3522e94aa0e23c490f1373bfee070206a193e /source4/configure.in
parentda9372463775fa09d081307fb78b109b90e8175a (diff)
downloadsamba-0ea253d728ef404ad9ef3e13e92b59d8890713aa.tar.gz
samba-0ea253d728ef404ad9ef3e13e92b59d8890713aa.tar.bz2
samba-0ea253d728ef404ad9ef3e13e92b59d8890713aa.zip
(merge from 3.0)
Fix for debian Bug#225328 by LaMont Jones <lamont@debian.org>, where the failure of our LFS test on ia64 caused the _GNU_SOURCE define not to be added, causeing strndup() not to be defined... This was due to strdup() bein implicitly declared, and casting pointer->int->pointer. I'll into when we really should define _GNU_SOURCE shortly, but the fix is correct anyway. Andrew Bartlett (This used to be commit f1cf5b8aa9897b79dfd00b963bc3803b6ff00dcb)
Diffstat (limited to 'source4/configure.in')
-rw-r--r--source4/configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/source4/configure.in b/source4/configure.in
index 78cc870963..746fb9eb89 100644
--- a/source4/configure.in
+++ b/source4/configure.in
@@ -394,6 +394,8 @@ exit(1);
AC_TRY_RUN([
#include <unistd.h>
#include <sys/utsname.h>
+#include <string.h>
+#include <stdlib.h>
main() {
#if _LFS64_LARGEFILE == 1
struct utsname uts;