summaryrefslogtreecommitdiff
path: root/source4/configure.in
diff options
context:
space:
mode:
authorStefan Metzmacher <metze@samba.org>2005-12-30 19:18:51 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 13:49:04 -0500
commit83acc688e3cb21d3fe25129f1fa1522872e6eec2 (patch)
tree093ee254dd6ffb0da50e745cb4c70241c94aecb5 /source4/configure.in
parent87a97acdfecbeb3651112639d2bb7eab3372171e (diff)
downloadsamba-83acc688e3cb21d3fe25129f1fa1522872e6eec2.tar.gz
samba-83acc688e3cb21d3fe25129f1fa1522872e6eec2.tar.bz2
samba-83acc688e3cb21d3fe25129f1fa1522872e6eec2.zip
r12615: prepare building with ../samba4/source/configure --srcdir=../samba4/source/
metze (This used to be commit bf35c74218476fc568e251bb337e794ed9d51fac)
Diffstat (limited to 'source4/configure.in')
-rw-r--r--source4/configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/source4/configure.in b/source4/configure.in
index bc8bfdc568..bd64cdf184 100644
--- a/source4/configure.in
+++ b/source4/configure.in
@@ -65,9 +65,6 @@ AC_TRY_RUN([#include "${srcdir-.}/build/tests/summary.c"],
AC_MSG_ERROR([summary failure. Aborting config]); exit 1;,
AC_MSG_WARN([cannot run when cross-compiling]))
-builddir=`pwd`
-AC_SUBST(builddir)
-
LIBS=`echo $LIBS | sed -e 's/ *//g'`
if test x"$LIBS" != x""; then
echo "LIBS: $LIBS"
@@ -114,5 +111,8 @@ $SMB_INFO_SUBSYSTEMS
$SMB_INFO_LIBRARIES
CEOF
-AC_OUTPUT_COMMANDS([$PERL -I. -Ibuild build/smb_build/main.pl],[PERL="$PERL";export PERL])
+AC_OUTPUT_COMMANDS(
+[$PERL -I${builddir} -I${srcdir} -I${srcdir}/build ${srcdir}/build/smb_build/main.pl],[
+PERL="$PERL";export PERL;export srcdir; export builddir;
+])
AC_OUTPUT