summaryrefslogtreecommitdiff
path: root/source4/configure.in
diff options
context:
space:
mode:
authorStefan Metzmacher <metze@samba.org>2005-08-04 16:49:17 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 13:31:13 -0500
commit56c112bbbc028bf7b74b47b22d41b74c7a3f9855 (patch)
tree821cb50bb21b77eb083370d11c3dd8eb93680ee5 /source4/configure.in
parent2ba1fa7b593706bdd1ad5bae982ed51b16dc3a83 (diff)
downloadsamba-56c112bbbc028bf7b74b47b22d41b74c7a3f9855.tar.gz
samba-56c112bbbc028bf7b74b47b22d41b74c7a3f9855.tar.bz2
samba-56c112bbbc028bf7b74b47b22d41b74c7a3f9855.zip
r9063: - don't pollute the global $LIBS variable with -ldl
- -lresolve seems to not being needed any more (it's actually not used, and the build farm seem to happy with it) - move socket and netif configure test to seperate files - don't pollute the global $LIBS variable with -lsocket ... - actually make use of the -lsocket when needed (should fix the solaris build) metze (This used to be commit adebd56be6f62323d56b6666ca0e02f85a33438e)
Diffstat (limited to 'source4/configure.in')
-rw-r--r--source4/configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/source4/configure.in b/source4/configure.in
index e4bcc64fe9..9689c7c45d 100644
--- a/source4/configure.in
+++ b/source4/configure.in
@@ -11,12 +11,14 @@ AC_CONFIG_HEADER(include/config.h)
sinclude(build/m4/env.m4)
sinclude(build/m4/rewrite.m4)
+sinclude(lib/replace/config.m4)
sinclude(lib/replace/win32/config.m4)
sinclude(lib/replace/repdir/config.m4)
sinclude(heimdal_build/config.m4)
sinclude(lib/popt/config.m4)
sinclude(lib/iconv.m4)
sinclude(lib/socket/config.m4)
+sinclude(lib/netif/config.m4)
sinclude(lib/talloc/config.m4)
sinclude(lib/tdb/config.m4)
sinclude(lib/ldb/sqlite3.m4)
@@ -65,6 +67,14 @@ AC_TRY_RUN([#include "${srcdir-.}/build/tests/summary.c"],
builddir=`pwd`
AC_SUBST(builddir)
+LIBS=`echo $LIBS | sed -e 's/ *//g'`
+if test x"$LIBS" != x""; then
+ echo "LIBS: $LIBS"
+ AC_MSG_WARN([the global \$LIBS variable contains some libraries!])
+ AC_MSG_WARN([this should not happen, please report to samba-technical@lists.samba.org!])
+ AC_MSG_ERROR([only _EXT macros from aclocal.m4 should be used!])
+fi
+
dnl Remove -L/usr/lib/? from LDFLAGS and LIBS
LIB_REMOVE_USR_LIB(LDFLAGS)
LIB_REMOVE_USR_LIB(LIBS)