summaryrefslogtreecommitdiff
path: root/source4/lib/ldb/configure.ac
diff options
context:
space:
mode:
authorStefan Metzmacher <metze@samba.org>2006-09-05 15:26:03 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 14:17:16 -0500
commit99b2e8fdc9f55d539399c7afcb26c5b733dcaafa (patch)
treed1486a15244c50fa5a977eb38a16ba19ea31254d /source4/lib/ldb/configure.ac
parent22498176804d4caa9ff67a9ec95308ad359adaa1 (diff)
downloadsamba-99b2e8fdc9f55d539399c7afcb26c5b733dcaafa.tar.gz
samba-99b2e8fdc9f55d539399c7afcb26c5b733dcaafa.tar.bz2
samba-99b2e8fdc9f55d539399c7afcb26c5b733dcaafa.zip
r18098: use m4_include() instead of sinclude()
this breaks ./autogen.sh in lib/ldb/, but the ldb build is broken anyway metze (This used to be commit 816fa197a73f5f309b6a113d997d21a70423361e)
Diffstat (limited to 'source4/lib/ldb/configure.ac')
-rw-r--r--source4/lib/ldb/configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/source4/lib/ldb/configure.ac b/source4/lib/ldb/configure.ac
index 5ef3d1cc96..1cca6024ff 100644
--- a/source4/lib/ldb/configure.ac
+++ b/source4/lib/ldb/configure.ac
@@ -48,10 +48,10 @@ AC_SUBST(MODULESDIR)
TESTS=""
EXTRA_OBJ=""
-sinclude(popt.m4)
-sinclude(replace/config.m4)
+m4_include(popt.m4)
+m4_include(../replace/libreplace.m4)
-sinclude(ldap.m4)
+m4_include(ldap.m4)
if test x"$with_ldap_support" = x"yes"; then
LIBS="$LIBS -llber -lldap"
CFLAGS="$CFLAGS -DHAVE_LDAP=1"
@@ -59,7 +59,7 @@ if test x"$with_ldap_support" = x"yes"; then
TESTS="$TESTS test-ldap.sh"
fi
-sinclude(sqlite3.m4)
+m4_include(sqlite3.m4)
if test x"$with_sqlite3_support" = x"yes"; then
LIBS="$LIBS -lsqlite3"
CFLAGS="$CFLAGS -DHAVE_SQLITE3=1"
@@ -70,10 +70,10 @@ fi
AC_SUBST(TESTS)
AC_SUBST(EXTRA_OBJ)
-sinclude(replace.m4)
+m4_include(replace.m4)
SMB_REPLACE_FUNCS(strtoll)
-sinclude(config.m4)
-sinclude(../talloc/config.m4)
-sinclude(../tdb/config.m4)
+m4_include(config.m4)
+m4_include(../talloc/config.m4)
+m4_include(../tdb/config.m4)
AC_OUTPUT(Makefile ldb.pc)