summaryrefslogtreecommitdiff
path: root/source4/lib/ldb/configure.ac
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2008-01-10 15:36:35 -0600
committerStefan Metzmacher <metze@samba.org>2008-01-10 09:42:04 -0600
commitfd39d2050c363556ae5277c52f1715f21c2d31fa (patch)
tree512365299b08e6aae8145a89e6ca03f7596ae9fe /source4/lib/ldb/configure.ac
parentdb5b0fcfb8d51bff5f7c62ce9c4b0daa71b919b1 (diff)
downloadsamba-fd39d2050c363556ae5277c52f1715f21c2d31fa.tar.gz
samba-fd39d2050c363556ae5277c52f1715f21c2d31fa.tar.bz2
samba-fd39d2050c363556ae5277c52f1715f21c2d31fa.zip
r26701: ldb: Build and install python modules when possible.
(This used to be commit 7a66d0eff6e2300cc82b4c7585f9c45afcc851a4)
Diffstat (limited to 'source4/lib/ldb/configure.ac')
-rw-r--r--source4/lib/ldb/configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/source4/lib/ldb/configure.ac b/source4/lib/ldb/configure.ac
index 73966e8f93..62a840e561 100644
--- a/source4/lib/ldb/configure.ac
+++ b/source4/lib/ldb/configure.ac
@@ -75,6 +75,19 @@ AC_LIBREPLACE_SHLD
AC_LIBREPLACE_SHLD_FLAGS
AC_LIBREPLACE_MDLD
AC_LIBREPLACE_MDLD_FLAGS
+AC_LIBREPLACE_RUNTIME_LIB_PATH_VAR
+
+AC_PATH_PROGS([PYTHON_CONFIG], [python2.6-config python2.5-config python2.4-config python-config])
+
+PYTHON_BUILD_TARGET="build-python"
+PYTHON_INSTALL_TARGET="install-python"
+AC_SUBST(PYTHON_BUILD_TARGET)
+AC_SUBST(PYTHON_INSTALL_TARGET)
+
+if test -z "$PYTHON_CONFIG"; then
+ PYTHON_BUILD_TARGET=""
+ PYTHON_INSTALL_TARGET=""
+fi
m4_include(libldb.m4)
AC_OUTPUT(Makefile ldb.pc)