summaryrefslogtreecommitdiff
path: root/source4/lib/ldb/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2006-08-23 04:53:47 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 14:16:34 -0500
commit309ef9069096ce09483e2f9a18f191fc53e1c7f4 (patch)
treedd85a81f6bd59c634a0620a4ad2929ad41999cc0 /source4/lib/ldb/configure.in
parent36cb569e9be142f0b4a4e584a365b35e8bfa454d (diff)
downloadsamba-309ef9069096ce09483e2f9a18f191fc53e1c7f4.tar.gz
samba-309ef9069096ce09483e2f9a18f191fc53e1c7f4.tar.bz2
samba-309ef9069096ce09483e2f9a18f191fc53e1c7f4.zip
r17738: solving the seemingly trivial problem of timegm() being missing on
some systems requires quite a large change in ldb. The core problem is that ldb doesn't have its own equivalent of lib/replace/, so we have no sane place to put things like timegm.c This patch moves part of lib/replace/ from Samba4 into ldb, and the next patch will remove those parts from Samba4. We will probably need to similarly move parts of lib/replace/ into lib/talloc/ and lib/tdb/, so that at each level the libraries have replacements for the functions they need, but higher level libraries don't need to re-include replacements if a lower level library already replaces the function (This used to be commit c2f6c217fb4a5c84499246480f00df40b0711074)
Diffstat (limited to 'source4/lib/ldb/configure.in')
-rw-r--r--source4/lib/ldb/configure.in12
1 files changed, 3 insertions, 9 deletions
diff --git a/source4/lib/ldb/configure.in b/source4/lib/ldb/configure.in
index 1e8e6a28e5..0571fb68e1 100644
--- a/source4/lib/ldb/configure.in
+++ b/source4/lib/ldb/configure.in
@@ -40,24 +40,18 @@ AC_CONFIG_HEADER(include/config.h)
AC_CHECK_LIB(dl, dlopen)
AC_CHECK_FUNCS(dlopen dlsym dlclose)
-AC_CHECK_TYPE(uint8_t, unsigned char)
-AC_CHECK_TYPE(int64_t, long long)
-AC_CHECK_TYPE(uint64_t, unsigned long long)
-
-AC_CHECK_TYPE(comparison_fn_t,
-[AC_DEFINE(HAVE_COMPARISON_FN_T, 1,[Whether or not we have comparison_fn_t])])
-
SHLIBEXT="so" # Should be set based on OS later on
AC_SUBST(SHLIBEXT)
AC_DEFINE_UNQUOTED(MODULESDIR, LIBDIR "/ldb" , [Modules directory] )
AC_SUBST(MODULESDIR)
-sinclude(popt.m4)
-
TESTS=""
EXTRA_OBJ=""
+sinclude(popt.m4)
+sinclude(replace/config.m4)
+
sinclude(ldap.m4)
if test x"$with_ldap_support" = x"yes"; then
LIBS="$LIBS -L/usr/lib -llber -lldap"