summaryrefslogtreecommitdiff
path: root/source4/lib/talloc/configure.ac
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2006-09-04 12:21:42 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 14:17:05 -0500
commit38fdde5d9bf15b10caa60ee216d278ba8d870c2e (patch)
treef5da0712c3bd704a0af17aa6d12d8c616a2d6e1b /source4/lib/talloc/configure.ac
parentf6f4d868ea7d3a01ec28c6855240882911cae039 (diff)
downloadsamba-38fdde5d9bf15b10caa60ee216d278ba8d870c2e.tar.gz
samba-38fdde5d9bf15b10caa60ee216d278ba8d870c2e.tar.bz2
samba-38fdde5d9bf15b10caa60ee216d278ba8d870c2e.zip
r18031: Merge my replace fixes:
* libreplace can now build stand-alone * add stub testsuite for libreplace * make talloc/tdb/ldb use libreplace (This used to be commit fe7ca4b1454e01a33ed0d53791ebffdd349298b4)
Diffstat (limited to 'source4/lib/talloc/configure.ac')
-rw-r--r--source4/lib/talloc/configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/source4/lib/talloc/configure.ac b/source4/lib/talloc/configure.ac
new file mode 100644
index 0000000000..253992cb1a
--- /dev/null
+++ b/source4/lib/talloc/configure.ac
@@ -0,0 +1,19 @@
+AC_PREREQ(2.50)
+AC_INIT(talloc.h)
+AC_CONFIG_SRCDIR([talloc.c])
+AC_SUBST(datarootdir)
+AC_PROG_CC
+if test "x$GCC" = "xyes"; then
+ CFLAGS="$CFLAGS -Wall -W"
+fi
+AC_PROG_INSTALL
+AC_PATH_PROG(XSLTPROC,xsltproc)
+DOC_TARGET=""
+if test -n "$XSLTPROC"; then
+ DOC_TARGET=doc
+fi
+AC_SUBST(DOC_TARGET)
+AC_CONFIG_HEADER(config.h)
+AC_SYS_LARGEFILE
+sinclude(config.m4)
+AC_OUTPUT(Makefile talloc.pc)