summaryrefslogtreecommitdiff
path: root/source4/lib/tdb/configure.ac
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2008-01-11 09:25:14 +1100
committerAndrew Bartlett <abartlet@samba.org>2008-01-11 09:25:14 +1100
commit80902a2a2b14bc27af0f195d18c40ccef9cb780c (patch)
tree792ae2b86096db9026933c7fe22c57ff7a401bf4 /source4/lib/tdb/configure.ac
parent7054ce65485482d1cc5fa4ff83272feb752e71c2 (diff)
parent84c9b6235ed52770eb6dfae8b75c346d435cb260 (diff)
downloadsamba-80902a2a2b14bc27af0f195d18c40ccef9cb780c.tar.gz
samba-80902a2a2b14bc27af0f195d18c40ccef9cb780c.tar.bz2
samba-80902a2a2b14bc27af0f195d18c40ccef9cb780c.zip
Merge commit 'origin/v4-0-test' into 4-0-local
(This used to be commit 4720f53a92644dd6959e18923924fbe01889111c)
Diffstat (limited to 'source4/lib/tdb/configure.ac')
-rw-r--r--source4/lib/tdb/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/source4/lib/tdb/configure.ac b/source4/lib/tdb/configure.ac
index 3237d29fb0..5747107f38 100644
--- a/source4/lib/tdb/configure.ac
+++ b/source4/lib/tdb/configure.ac
@@ -12,4 +12,14 @@ AC_LD_SHLIBEXT
AC_LIBREPLACE_SHLD
AC_LIBREPLACE_SHLD_FLAGS
m4_include(libtdb.m4)
+AC_PATH_PROGS([PYTHON_CONFIG], [python2.6-config python2.5-config python2.4-config python-config])
+
+PYTHON_BUILD_TARGET="build-python"
+PYTHON_INSTALL_TARGET="install-python"
+AC_SUBST(PYTHON_BUILD_TARGET)
+AC_SUBST(PYTHON_INSTALL_TARGET)
+if test -z "$PYTHON_CONFIG"; then
+ PYTHON_BUILD_TARGET=""
+ PYTHON_INSTALL_TARGET=""
+fi
AC_OUTPUT(Makefile tdb.pc)