summaryrefslogtreecommitdiff
path: root/source4/pidl/Makefile.PL
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2007-01-05 20:13:48 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 14:36:57 -0500
commit5a162488a1018d44b28475538bffeeef56b453b6 (patch)
tree15b1df6e8a916b671cb7a7809eeacd6b97d08a29 /source4/pidl/Makefile.PL
parent3c7a84a2055dde0953a240ce5b03c943f4f2d8f1 (diff)
downloadsamba-5a162488a1018d44b28475538bffeeef56b453b6.tar.gz
samba-5a162488a1018d44b28475538bffeeef56b453b6.tar.bz2
samba-5a162488a1018d44b28475538bffeeef56b453b6.zip
r20562: Start building expr parser. Add separate copy of Yapp::Driver
rather than including it in each individual parser. (This used to be commit 26853d7d99f7305981bcadaabfe6accf254321e7)
Diffstat (limited to 'source4/pidl/Makefile.PL')
-rwxr-xr-xsource4/pidl/Makefile.PL7
1 files changed, 5 insertions, 2 deletions
diff --git a/source4/pidl/Makefile.PL b/source4/pidl/Makefile.PL
index f5cd3e4eff..8167cfd6f8 100755
--- a/source4/pidl/Makefile.PL
+++ b/source4/pidl/Makefile.PL
@@ -3,13 +3,16 @@ WriteMakefile(
'NAME' => 'Parse::Pidl',
'VERSION_FROM' => 'lib/Parse/Pidl.pm',
'EXE_FILES' => [ 'pidl' ],
- 'test' => { 'TESTS' => 'tests/*.pl' }
+ 'test' => { 'TESTS' => 'tests/*.pl' },
+ 'PMLIBDIRS' => [ 'lib/Parse/Pidl']
);
sub MY::postamble {
<<'EOT';
lib/Parse/Pidl/IDL.pm: idl.yp
- yapp -s -m 'Parse::Pidl::IDL' -o lib/Parse/Pidl/IDL.pm idl.yp
+ yapp -m 'Parse::Pidl::IDL' -o lib/Parse/Pidl/IDL.pm idl.yp
+lib/Parse/Pidl/Expr.pm: expr.yp
+ yapp -m 'Parse::Pidl::Expr' -o lib/Parse/Pidl/Expr.pm expr.yp
EOT
}