summaryrefslogtreecommitdiff
path: root/source4/pidl/Makefile.PL
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2005-08-21 23:17:35 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 13:34:17 -0500
commitefc03df292aa84edb592c22191dbf86cdf8c32d0 (patch)
tree8a72f715ced0922effaa6dc48000bb1b48b82678 /source4/pidl/Makefile.PL
parent6e388c27d86d77f2c7f9414fbb152c246ca53022 (diff)
downloadsamba-efc03df292aa84edb592c22191dbf86cdf8c32d0.tar.gz
samba-efc03df292aa84edb592c22191dbf86cdf8c32d0.tar.bz2
samba-efc03df292aa84edb592c22191dbf86cdf8c32d0.zip
r9459: Move pidl up one level (to prevent too much nesting)
(This used to be commit e48202275e60c18e464457d200daeb953386e221)
Diffstat (limited to 'source4/pidl/Makefile.PL')
-rwxr-xr-xsource4/pidl/Makefile.PL16
1 files changed, 16 insertions, 0 deletions
diff --git a/source4/pidl/Makefile.PL b/source4/pidl/Makefile.PL
new file mode 100755
index 0000000000..ae862bfdb5
--- /dev/null
+++ b/source4/pidl/Makefile.PL
@@ -0,0 +1,16 @@
+use ExtUtils::MakeMaker;
+WriteMakefile(
+ 'NAME' => 'Parse::Pidl',
+ 'VERSION_FROM' => 'Parse/Pidl.pm',
+ 'EXE_FILES' => [ 'pidl' ],
+ 'PMLIBDIRS' => [ 'Parse' ],
+ 'C' => [],
+ 'test' => { 'TESTS' => 'tests/*.pl' }
+);
+
+sub MY::postamble {
+<<'EOT';
+Parse/Pidl/IDL.pm :: idl.yp
+ yapp -s -m 'Parse::Pidl::IDL' -o 'Parse/Pidl/IDL.pm' idl.yp
+EOT
+}