summaryrefslogtreecommitdiff
path: root/docs/docbook/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'docs/docbook/configure.in')
-rw-r--r--docs/docbook/configure.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/docs/docbook/configure.in b/docs/docbook/configure.in
index c115fd88c0..92e98d3e82 100644
--- a/docs/docbook/configure.in
+++ b/docs/docbook/configure.in
@@ -11,12 +11,13 @@ AC_PATH_PROG(NSGMLS, nsgmls)
AC_PATH_PROG(HTMLDOC, htmldoc)
AC_PATH_PROG(ONSGMLS, onsgmls)
AC_PATH_PROG(SGMLSPL, sgmlspl)
+AC_PATH_PROG(PERL, perl)
dnl ----------------------------------------------------------------
dnl --with-sgml-share
SGML_SHARE="/usr/local/share/sgml"
-AC_ARG_WITH(SGML_SHARE,
+AC_ARG_WITH(sgml-share,
[ --with-sgml-share=DIR change the default location of SGML stylesheets],
[case "$withval" in
no) SGML_SHARE=""
@@ -32,9 +33,12 @@ AC_ARG_WITH(SGML_SHARE,
esac
])dnl
-AC_SUBST(SGML_SHARE)dnl
-
+# The Makefile requires docbook2X in the share/sgml directory
+if [ ! test -f $SGML_SHARE/docbook2X/docbook2man-spec.pl ]; then
+ AC_MSG_ERROR("Unable to find dockbook2X. Make sure it is installed and that the sgml-share path is correct.")
+fi
+AC_SUBST(SGML_SHARE)dnl
DOC_BUILD_DATE=`date '+%d-%m-%Y'`
AC_SUBST(DOC_BUILD_DATE)