summaryrefslogtreecommitdiff
path: root/packaging/Debian/debian/patches/python-linker.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/Debian/debian/patches/python-linker.patch')
-rw-r--r--packaging/Debian/debian/patches/python-linker.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/packaging/Debian/debian/patches/python-linker.patch b/packaging/Debian/debian/patches/python-linker.patch
new file mode 100644
index 0000000000..1cbf4b7c2c
--- /dev/null
+++ b/packaging/Debian/debian/patches/python-linker.patch
@@ -0,0 +1,13 @@
+diff -ur samba-3.0.0beta1.orig/source/python/setup.py samba-3.0.0beta1/source/python/setup.py
+--- samba-3.0.0beta1.orig/source/python/setup.py 2003-06-07 12:57:36.000000000 -0500
++++ samba-3.0.0beta1/source/python/setup.py 2003-06-19 17:26:48.000000000 -0500
+@@ -57,6 +57,9 @@
+ if lib[0:2] == "-L":
+ library_dirs.append(lib[2:])
+ continue
++ if lib[0:4] == "-Wl,":
++ print "Ignoring linker flag '%s' in $LIBS variable passed to setup.py" % lib
++ continue
+ print "Unknown entry '%s' in $LIBS variable passed to setup.py" % lib
+ sys.exit(1)
+