summaryrefslogtreecommitdiff
path: root/packaging/Debian/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/Debian/debian/patches')
-rw-r--r--packaging/Debian/debian/patches/pam_smbpass_linkage.patch26
-rw-r--r--packaging/Debian/debian/patches/python-linker.patch13
-rw-r--r--packaging/Debian/debian/patches/samba.patch60
3 files changed, 71 insertions, 28 deletions
diff --git a/packaging/Debian/debian/patches/pam_smbpass_linkage.patch b/packaging/Debian/debian/patches/pam_smbpass_linkage.patch
new file mode 100644
index 0000000000..3d1fab8ab0
--- /dev/null
+++ b/packaging/Debian/debian/patches/pam_smbpass_linkage.patch
@@ -0,0 +1,26 @@
+diff -ur samba-3.0.0beta1.orig/source/Makefile.in samba-3.0.0beta1/source/Makefile.in
+--- samba-3.0.0beta1.orig/source/Makefile.in 2003-06-16 23:59:19.000000000 -0500
++++ samba-3.0.0beta1/source/Makefile.in 2003-06-17 00:13:50.000000000 -0500
+@@ -582,9 +582,9 @@
+
+ PAM_SMBPASS_OBJ_0 = pam_smbpass/pam_smb_auth.o pam_smbpass/pam_smb_passwd.o \
+ pam_smbpass/pam_smb_acct.o pam_smbpass/support.o \
+- libsmb/smbencrypt.o libsmb/smbdes.o libsmb/nterr.o \
+- $(PARAM_OBJ) $(LIB_OBJ) $(PASSDB_OBJ) $(GROUPDB_OBJ) \
+- $(SECRETS_OBJ) $(UBIQX_OBJ) $(IDMAP_OBJ)
++ $(LIBSAMBA_OBJ) $(PARAM_OBJ) $(LIB_OBJ) $(PASSDB_OBJ) \
++ $(GROUPDB_OBJ) $(SECRETS_OBJ) $(UBIQX_OBJ) $(IDMAP_OBJ) \
++ $(SMBLDAP_OBJ)
+
+ PAM_SMBPASS_PICOOBJ = $(PAM_SMBPASS_OBJ_0:.o=.po)
+
+@@ -1080,7 +1080,8 @@
+
+ bin/pam_smbpass.@SHLIBEXT@: $(PAM_SMBPASS_PICOOBJ)
+ @echo "Linking shared library $@"
+- @$(SHLD) $(LDSHFLAGS) -o $@ $(PAM_SMBPASS_PICOOBJ) -lpam $(DYNEXP) $(LIBS) -lc
++ @$(SHLD) $(LDSHFLAGS) -o $@ $(PAM_SMBPASS_PICOOBJ) -lpam $(DYNEXP) \
++ $(PASSDBLIBS) $(LIBS) -lc
+
+ bin/libmsrpc.a: $(LIBMSRPC_PICOBJ)
+ @-$(AR) -rc $@ $(LIBMSRPC_PICOBJ)
diff --git a/packaging/Debian/debian/patches/python-linker.patch b/packaging/Debian/debian/patches/python-linker.patch
new file mode 100644
index 0000000000..1cbf4b7c2c
--- /dev/null
+++ b/packaging/Debian/debian/patches/python-linker.patch
@@ -0,0 +1,13 @@
+diff -ur samba-3.0.0beta1.orig/source/python/setup.py samba-3.0.0beta1/source/python/setup.py
+--- samba-3.0.0beta1.orig/source/python/setup.py 2003-06-07 12:57:36.000000000 -0500
++++ samba-3.0.0beta1/source/python/setup.py 2003-06-19 17:26:48.000000000 -0500
+@@ -57,6 +57,9 @@
+ if lib[0:2] == "-L":
+ library_dirs.append(lib[2:])
+ continue
++ if lib[0:4] == "-Wl,":
++ print "Ignoring linker flag '%s' in $LIBS variable passed to setup.py" % lib
++ continue
+ print "Unknown entry '%s' in $LIBS variable passed to setup.py" % lib
+ sys.exit(1)
+
diff --git a/packaging/Debian/debian/patches/samba.patch b/packaging/Debian/debian/patches/samba.patch
index 8dcfac5e65..3925081735 100644
--- a/packaging/Debian/debian/patches/samba.patch
+++ b/packaging/Debian/debian/patches/samba.patch
@@ -1,6 +1,6 @@
-diff -uNr samba-3.0alpha23.orig/source/client/smbmount.c samba-3.0alpha23/source/client/smbmount.c
---- samba-3.0alpha23.orig/source/client/smbmount.c 2003-03-30 20:28:28.000000000 -0600
-+++ samba-3.0alpha23/source/client/smbmount.c 2003-04-04 21:05:58.000000000 -0600
+diff -uNr samba-3.0.0beta1.orig/source/client/smbmount.c samba-3.0.0beta1/source/client/smbmount.c
+--- samba-3.0.0beta1.orig/source/client/smbmount.c 2003-06-07 12:57:32.000000000 -0500
++++ samba-3.0.0beta1/source/client/smbmount.c 2003-06-30 20:12:22.000000000 -0500
@@ -765,7 +765,7 @@
*lp = 0;
pstrcpy(password,lp+1);
@@ -28,9 +28,9 @@ diff -uNr samba-3.0alpha23.orig/source/client/smbmount.c samba-3.0alpha23/source
}
strupper(username);
}
-diff -uNr samba-3.0alpha23.orig/source/script/installbin.sh samba-3.0alpha23/source/script/installbin.sh
---- samba-3.0alpha23.orig/source/script/installbin.sh 2002-04-22 13:16:20.000000000 -0500
-+++ samba-3.0alpha23/source/script/installbin.sh 2003-04-04 21:05:58.000000000 -0600
+diff -uNr samba-3.0.0beta1.orig/source/script/installbin.sh samba-3.0.0beta1/source/script/installbin.sh
+--- samba-3.0.0beta1.orig/source/script/installbin.sh 2002-04-22 13:16:20.000000000 -0500
++++ samba-3.0.0beta1/source/script/installbin.sh 2003-06-30 20:12:22.000000000 -0500
@@ -22,9 +22,11 @@
chmod $INSTALLPERMS $BINDIR/$p2
@@ -46,27 +46,31 @@ diff -uNr samba-3.0alpha23.orig/source/script/installbin.sh samba-3.0alpha23/sou
done
-diff -uNr samba-3.0alpha23.orig/source/smbd/service.c samba-3.0alpha23/source/smbd/service.c
---- samba-3.0alpha23.orig/source/smbd/service.c 2003-03-30 20:28:31.000000000 -0600
-+++ samba-3.0alpha23/source/smbd/service.c 2003-04-04 21:05:58.000000000 -0600
-@@ -890,6 +890,14 @@
- change_to_root_user();
- }
+diff -uNr samba-3.0.0beta1.orig/source/smbd/service.c samba-3.0.0beta1/source/smbd/service.c
+--- samba-3.0.0beta1.orig/source/smbd/service.c 2003-06-07 12:57:39.000000000 -0500
++++ samba-3.0.0beta1/source/smbd/service.c 2003-06-30 20:12:57.000000000 -0500
+@@ -880,6 +880,9 @@
+ file_close_conn(conn);
+ dptr_closecnum(conn);
-+ /* If our root postexec command includes a call to 'unmount', we want
-+ to make sure we aren't blocking the mount point. */
-+ /* I think this patch should go here, but I am not sure since
-+ the code looks very different than in Samba 2.2.2. Will come
-+ back later; should check what change_to_root_user() does. Eloy.-
-+ vfs_ChDir(conn,"/");
-+ /*
++ /* make sure we leave the directory available for unmount */
++ vfs_ChDir(conn, "/");
+
- change_to_root_user();
- /* execute any "root postexec = " line */
- if (*lp_rootpostexec(SNUM(conn))) {
-diff -uNr samba-3.0alpha23.orig/source/smbwrapper/smbsh.c samba-3.0alpha23/source/smbwrapper/smbsh.c
---- samba-3.0alpha23.orig/source/smbwrapper/smbsh.c 2003-03-30 20:28:31.000000000 -0600
-+++ samba-3.0alpha23/source/smbwrapper/smbsh.c 2003-04-04 21:05:58.000000000 -0600
+ /* execute any "postexec = " line */
+ if (*lp_postexec(SNUM(conn)) &&
+ change_to_user(conn, vuid)) {
+@@ -899,8 +902,5 @@
+ smbrun(cmd,NULL);
+ }
+
+- /* make sure we leave the directory available for unmount */
+- vfs_ChDir(conn, "/");
+-
+ conn_free(conn);
+ }
+diff -uNr samba-3.0.0beta1.orig/source/smbwrapper/smbsh.c samba-3.0.0beta1/source/smbwrapper/smbsh.c
+--- samba-3.0.0beta1.orig/source/smbwrapper/smbsh.c 2003-06-07 12:57:40.000000000 -0500
++++ samba-3.0.0beta1/source/smbwrapper/smbsh.c 2003-06-30 20:12:22.000000000 -0500
@@ -36,7 +36,7 @@
int main(int argc, char *argv[])
{
@@ -76,9 +80,9 @@ diff -uNr samba-3.0alpha23.orig/source/smbwrapper/smbsh.c samba-3.0alpha23/sourc
pstring line, wd;
int opt;
extern char *optarg;
-diff -uNr samba-3.0alpha23.orig/source/web/diagnose.c samba-3.0alpha23/source/web/diagnose.c
---- samba-3.0alpha23.orig/source/web/diagnose.c 2003-01-18 13:03:58.000000000 -0600
-+++ samba-3.0alpha23/source/web/diagnose.c 2003-04-04 21:05:58.000000000 -0600
+diff -uNr samba-3.0.0beta1.orig/source/web/diagnose.c samba-3.0.0beta1/source/web/diagnose.c
+--- samba-3.0.0beta1.orig/source/web/diagnose.c 2003-06-07 12:57:41.000000000 -0500
++++ samba-3.0.0beta1/source/web/diagnose.c 2003-06-30 20:12:22.000000000 -0500
@@ -70,6 +70,7 @@
static struct cli_state cli;
extern struct in_addr loopback_ip;