summaryrefslogtreecommitdiff
path: root/packaging/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/debian/rules')
-rwxr-xr-xpackaging/debian/rules73
1 files changed, 39 insertions, 34 deletions
diff --git a/packaging/debian/rules b/packaging/debian/rules
index 113347e4e5..7b303f728e 100755
--- a/packaging/debian/rules
+++ b/packaging/debian/rules
@@ -1,15 +1,14 @@
#!/usr/bin/make -f
-# By Jelmer Vernooij
+# By Jelmer Vernooij <jelmer@samba.org>
# Made with the aid of debmake, by Christoph Lameter,
# based on the sample debian/rules file for GNU hello by Ian Jackson.
-
SOURCEPATH=../../source
package=samba4
configure:
- $(checkdir)
+ dh_testdir
cd $(SOURCEPATH) && ./autogen.sh
cd $(SOURCEPATH) && ./configure --with-fhs \
--prefix=/usr \
@@ -24,50 +23,56 @@ configure:
--with-syslog \
--with-readline \
--with-ldap
- touch configure
+ touch $@
build: configure
- $(checkdir)
+ dh_testdir
cd $(SOURCEPATH) && $(MAKE) proto all
- touch build
+ touch $@
clean:
- $(checkdir)
+ dh_testdir
+ dh_clean
rm -f build
-cd $(SOURCEPATH) && $(MAKE) clean
- rm -f `find . -name "*~"`
- rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
- rm -f debian/*substvars
-binary-indep: checkroot build
- $(checkdir)
+binary-indep: build install
+ dh_testdir -i
+ dh_testroot -i
+ dh_installdocs -i
+ dh_installchangelogs -i
+ dh_compress -i
+ dh_fixperms -i
+ dh_python -i
+ dh_installdeb -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
# There are no architecture-independent files to be uploaded
# generated by this package. If there were any they would be
# made here.
-binary-arch: checkroot build
- $(checkdir)
- rm -rf debian/tmp `find debian/* -type d ! -name CVS`
- install -d debian/tmp
- cd debian/tmp && install -d `cat ../dirs`
- cd $(SOURCEPATH) && $(MAKE) install DESTDIR=`pwd`/../packaging/debian/tmp
- mkdir -p debian/tmp/usr/share/man/man1
- mkdir -p debian/tmp/usr/share/man/man7
- cp $(SOURCEPATH)/build/pidl/pidl.pl debian/tmp/usr/bin/pidl
- debstd
- dpkg-gencontrol -isp -psamba4
- chown -R root:root debian/tmp
- chmod -R go=rX debian/tmp
- dpkg --build debian/tmp ..
+install: build
+ dh_clean -k
+ dh_installdirs
+ $(MAKE) -C $(SOURCEPATH) install DESTDIR=`pwd`/../packaging/debian/tmp
-define checkdir
- test -f debian/rules
-endef
+binary-arch: build install
+ dh_testdir -a
+ dh_testroot -a
+ dh_installdocs -a
+ dh_installman -a
+ dh_strip -a
+ dh_python -a
+ dh_compress -a
+ dh_fixperms -a
+ dh_makeshlibs -a
+ dh_installdeb -a
+ dh_shlibdeps -a
+ dh_gencontrol -a
+ dh_md5sums -a
+ dh_builddeb -a
binary: binary-indep binary-arch
-checkroot:
- $(checkdir)
- test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot
+.PHONY: binary binary-arch binary-indep clean