summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4065f8e40a..6946ab06b3 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2654,6 +2654,15 @@ if test x"$with_ads_support" != x"no"; then
[Whether in-memory keytabs are supported])
fi
+ AC_CHECK_MEMBER(krb5_keytab_entry.key,
+ AC_DEFINE(HAVE_KRB5_KEYTAB_ENTRY_KEY, 1,
+ [Whether krb5_keytab_entry has key member]), [],
+ [#include <krb5.h>])
+
+ AC_CHECK_MEMBER(krb5_keytab_entry.keyblock,
+ AC_DEFINE(HAVE_KRB5_KEYTAB_ENTRY_KEYBLOCK, 1,
+ [Whether krb5_keytab_entry has keyblock member]), [],
+ [#include <krb5.h>])
if test x"$ac_cv_lib_ext_krb5_krb5_mk_req_extended" = x"yes"; then
AC_DEFINE(HAVE_KRB5,1,[Whether to have KRB5 support])