summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index baeebd6654..3a75b32aaf 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2807,6 +2807,19 @@ AC_SUBST(BUILD_POPT)
AC_SUBST(FLAGS1)
#################################################
+# Check if the user wants Python
+
+# At the moment, you can use this to set which Python binary to link
+# against. (Libraries built for Python2.2 can't be used by 2.1,
+# though they can coexist in different directories.) In the future
+# this might make the Python stuff be built by default.
+
+AC_ARG_WITH(python,
+[ --with-python=PYTHONNAME build Python libraries],
+[ PYTHON=${withval-python} ])
+AC_SUBST(PYTHON)
+
+#################################################
# do extra things if we are running insure
if test "${ac_cv_prog_CC}" = "insure"; then