summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index b9e8c94b42..3bd8995fd7 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -23,11 +23,15 @@ AC_SUBST(LIBSMBCLIENT_SHARED)
# compile with optimisation and without debugging by default
CFLAGS="-O ${CFLAGS}"
-AC_ARG_ENABLE(debug, [ --enable-debug turn on debugging [default=no]],
+AC_ARG_ENABLE(debug, [ --enable-debug turn on debugging [default=no]],
[if eval "test x$enable_debug = xyes"; then
CFLAGS="${CFLAGS} -g"
fi])
+AC_ARG_ENABLE(developer, [ --enable-developer turn on developer warnings and debugging [default=no]],
+ [if eval "test x$enable_developer = xyes"; then
+ CFLAGS="${CFLAGS} -g -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -DDEBUG_PASSWORD -DDEVELOPER"
+ fi])
dnl Checks for programs.
AC_PROG_CC