summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 54f40d35fd..d61b355c8e 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -662,7 +662,9 @@ PICFLAG=""
PICSUFFIX="po"
POBAD_CC="#"
SHLIBEXT="so"
+# Assume non-shared by default and override below
BLDSHARED="false"
+AC_MSG_CHECKING([ability to build shared libraries])
# and these are for particular systems
case "$host_os" in
@@ -750,6 +752,11 @@ case "$host_os" in
LDSHFLAGS="-G"
;;
esac
+AC_MSG_RESULT($BLDSHARED)
+AC_MSG_CHECKING([linker flags for shared libraries])
+AC_MSG_RESULT([$LDSHFLAGS])
+AC_MSG_CHECKING([compiler flags for position-independent code])
+AC_MSG_RESULT([$PICFLAGS])
# this updates our target list if we can build shared libs
if test $BLDSHARED = true; then