summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 0b5d807239..82c60d43e9 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -38,6 +38,9 @@ AC_PROG_CC
AC_PROG_INSTALL
AC_PROG_AWK
+dnl needed before AC_TRY_COMPILE
+AC_ISC_POSIX
+
dnl Check if C compiler understands -c and -o at the same time
AC_PROG_CC_C_O
if eval "test \"`echo '$ac_cv_prog_cc_'${ac_cc}_c_o`\" = no"; then
@@ -317,6 +320,11 @@ fi
AC_CHECK_LIB(dl, dlopen, [LIBS="$LIBS -ldl";
AC_DEFINE(HAVE_LIBDL)])
+############################################
+# we need krb5 for w2k ADS authentication
+AC_CHECK_LIB(krb5, krb5_mk_req_extended, [LIBS="$LIBS -lkrb5";
+ AC_DEFINE(HAVE_KRB5)])
+
############################################
# check if the compiler can do immediate structures