summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 529b29b044..46c98aa12c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -5548,6 +5548,29 @@ if test "x$have_cluster_support" = "xyes" ; then
fi
if test "x$have_cluster_support" = "xyes" ; then
+ AC_HAVE_DECL(CTDB_CONTROL_CHECK_SRVIDS,[
+ #include "confdefs.h"
+ #define NO_CONFIG_H
+ #include "replace.h"
+ #include "system/wait.h"
+ #include "system/network.h"
+ #include <talloc.h>
+ #include <tdb.h>
+ #include <ctdb.h>
+ #include <ctdb_private.h>
+ ])
+ if test x"$ac_cv_have_CTDB_CONTROL_CHECK_SRVIDS_decl" != x"yes"
+ then
+ if test "x$enable_old_ctdb" = "xyes" ; then
+ AC_MSG_WARN([ignoring missing CHECK_SRVIDS (--enable-old-ctdb)])
+ else
+ ctdb_broken="support for CHECK_SRVIDS control missing"
+ have_cluster_support=no
+ fi
+ fi
+fi
+
+if test "x$have_cluster_support" = "xyes" ; then
# In ctdb 1.0.57, ctdb_control_tcp was temporarily renamed
# to ctdb_tcp_client.
AC_CHECK_TYPE(struct ctdb_tcp_client,[