summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 14698e401f..af5d9200c9 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -58,6 +58,12 @@ AC_TRY_COMPILE([#include <errno.h>],[int i = errno],
echo yes; AC_DEFINE(HAVE_ERRNO_DECL),
echo no)
+# stupid glibc has the functions but no declaration. grrrr.
+echo $ac_n "checking for setresuid declaration $ac_c"
+AC_TRY_COMPILE([#include <unistd.h>],[int i = setresuid],
+echo yes; AC_DEFINE(HAVE_SETRESUID_DECL),
+echo no)
+
AC_FUNC_MEMCMP
###############################################