summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 0796ff2d7d..0e972e766b 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2868,11 +2868,12 @@ AC_ARG_WITH(fake-kaserver,
if test x"$samba_cv_WITH_AFS" != x"no" ||
test x"$samba_cv_WITH_FAKE_KASERVER" != x"no"; then
+ # see if this box has the OpenSSL DES libraries
+ AC_CHECK_LIB( crypto, DES_pcbc_encrypt, LIBS="$LIBS -lcrypto" , [AC_ERROR(OpenSSL library: libcrypto ot found!)] )
+
# see if this box has the afs-headers in /usr/include/afs
AC_MSG_CHECKING(for /usr/include/afs)
if test -d /usr/include/afs; then
- CFLAGS="$CFLAGS -I/usr/include/afs"
- CPPFLAGS="$CPPFLAGS -I/usr/include/afs"
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)