summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f8386e2275..fb2ed2ee73 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3149,11 +3149,21 @@ AC_SUBST(FLAGS1)
# though they can coexist in different directories.) In the future
# this might make the Python stuff be built by default.
+# If you don't specify --with-python, we assume "python" anyhow,
+# because the extensions are not built until you specifically "make
+# python_ext". --without-python turns them off. Perhaps in the
+# future --with-python should make them automatically built by make
+# all.
+
+PYTHON=python
+
AC_ARG_WITH(python,
[ --with-python=PYTHONNAME build Python libraries],
[ case "${withval-python}" in
yes)
- PYTHON=python
+ ;;
+ no)
+ PYTHON=
;;
*)
PYTHON=${withval-python}