summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in97
1 files changed, 44 insertions, 53 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 8b78a3941a..1910c88c14 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -131,10 +131,16 @@ AC_SUBST(sbindir)
dnl Unique-to-Samba variables we'll be playing with.
AC_SUBST(SHELL)
+AC_SUBST(RUNPROG)
+AC_SUBST(MPROGS)
AC_SUBST(LDSHFLAGS)
AC_SUBST(SONAMEFLAG)
AC_SUBST(SHLD)
AC_SUBST(HOST_OS)
+AC_SUBST(PAM_MOD)
+AC_SUBST(WRAP)
+AC_SUBST(WRAP32)
+AC_SUBST(WRAPPROG)
AC_SUBST(PICFLAG)
AC_SUBST(PICSUFFIX)
AC_SUBST(POBAD_CC)
@@ -143,10 +149,6 @@ AC_SUBST(LIBSMBCLIENT_SHARED)
AC_SUBST(LIBSMBCLIENT)
AC_SUBST(PRINTLIBS)
AC_SUBST(AUTHLIBS)
-AC_SUBST(SHLIB_PROGS)
-AC_SUBST(EXTRA_BIN_PROGS)
-AC_SUBST(EXTRA_SBIN_PROGS)
-AC_SUBST(EXTRA_ALL_TARGETS)
# compile with optimization and without debugging by default
CFLAGS="-O ${CFLAGS}"
@@ -734,7 +736,9 @@ fi
# Check if we have execl, if not we need to compile smbrun.
AC_CHECK_FUNCS(execl)
if test x"$ac_cv_func_execl" = x"no"; then
- EXTRA_BIN_PROGS="$EXTRA_BIN_PROGS bin/smbrun"
+ RUNPROG="bin/smbrun"
+else
+ RUNPROG=""
fi
AC_CHECK_FUNCS(dlopen dlclose dlsym dlerror waitpid getcwd strdup strndup strnlen strtoul strerror chown fchown chmod fchmod chroot link mknod mknod64)
@@ -1903,7 +1907,6 @@ AC_ARG_WITH(smbwrapper,
WRAP=""
WRAP32=""
fi
- EXTRA_ALL_TARGETS="$EXTRA_ALL_TARGETS $WRAPPROG $WRAP $WRAP32"
;;
*)
AC_MSG_RESULT(no)
@@ -2090,21 +2093,21 @@ fi
########################################################
# Compile with MySQL support?
-AM_PATH_MYSQL([0.11.0],[MODULE_MYSQL=bin/mysql.so],[MODULE_MYSQL=])
+AM_PATH_MYSQL([0.11.0],[MODULE_MYSQL=bin/pdb_mysql.so],[MODULE_MYSQL=])
CFLAGS="$CFLAGS $MYSQL_CFLAGS"
AC_SUBST(MODULE_MYSQL)
########################################################
# Compile with XML support?
-AM_PATH_XML2([2.0.0],[MODULE_XML=bin/xml.so],[MODULE_XML=])
+AM_PATH_XML2([2.0.0],[MODULE_XML=bin/pdb_xml.so],[MODULE_XML=])
CFLAGS="$CFLAGS $XML_CFLAGS"
AC_SUBST(MODULE_XML)
#################################################
# check for automount support
-AC_MSG_CHECKING(whether to use automount)
+AC_MSG_CHECKING(whether to use AUTOMOUNT)
AC_ARG_WITH(automount,
-[ --with-automount Include automount support (default=no)],
+[ --with-automount Include AUTOMOUNT support (default=no)],
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)
@@ -2119,16 +2122,16 @@ AC_ARG_WITH(automount,
#################################################
# check for smbmount support
-AC_MSG_CHECKING(whether to use smbmount)
+AC_MSG_CHECKING(whether to use SMBMOUNT)
AC_ARG_WITH(smbmount,
-[ --with-smbmount Include smbmount (Linux only) support (default=no)],
+[ --with-smbmount Include SMBMOUNT (Linux only) support (default=no)],
[ case "$withval" in
yes)
case "$host_os" in
*linux*)
AC_MSG_RESULT(yes)
AC_DEFINE(WITH_SMBMOUNT,1,[Whether to build smbmount])
- EXTRA_BIN_PROGS="$EXTRA_BIN_PROGS bin/smbmount bin/smbmnt bin/smbumount"
+ MPROGS="bin/smbmount bin/smbmnt bin/smbumount"
;;
*)
AC_MSG_ERROR(not on a linux system!)
@@ -2137,9 +2140,11 @@ AC_ARG_WITH(smbmount,
;;
*)
AC_MSG_RESULT(no)
+ MPROGS=
;;
esac ],
AC_MSG_RESULT(no)
+ MPROGS=
)
@@ -2179,10 +2184,12 @@ AC_ARG_WITH(pam_smbpass,
if test x$PICFLAG = x; then
AC_MSG_RESULT([No support for PIC code - disabling pam_smbpass])
+ PAM_MOD=""
elif test x$ac_cv_lib_pam_pam_get_data = xno; then
AC_MSG_RESULT([No libpam found -- disabling pam_smbpass])
+ PAM_MOD=""
else
- SHLIB_PROGS="$SHLIB_PROGS bin/pam_smbpass.so"
+ PAM_MOD="bin/pam_smbpass.so"
fi
;;
*)
@@ -2222,24 +2229,6 @@ if test x"$samba_cv_HAVE_TRUNCATED_SALT" = x"yes"; then
fi
fi
-# New experimental SAM system
-
-AC_MSG_CHECKING([whether to build the new (experimental) SAM database])
-AC_ARG_WITH(sam,
-[ --with-sam Build new (experimental) SAM database (default=no)],
-[ case "$withval" in
- yes)
- AC_MSG_RESULT(yes)
- AC_DEFINE(WITH_SAM,1,[Whether to build the new (experimental) SAM database])
- ;;
- *)
- AC_MSG_RESULT(no)
- ;;
- esac ],
- AC_MSG_RESULT(no)
-)
-
-
########################################################################################
##
## TESTS FOR SAM BACKENDS. KEEP THESE GROUPED TOGETHER
@@ -2991,7 +2980,8 @@ samba_cv_HAVE_SENDFILEV=yes,samba_cv_HAVE_SENDFILEV=no)])
#################################################
# Check whether winbind is supported on this platform. If so we need to
-# build and install client programs, sbin programs and shared libraries
+# build and install client programs (WINBIND_TARGETS), sbin programs
+# (WINBIND_STARGETS) and shared libraries (WINBIND_LTARGETS).
AC_MSG_CHECKING(whether to build winbind)
@@ -3016,9 +3006,6 @@ case "$host_os" in
;;
esac
-AC_SUBST(WINBIND_NSS_EXTRA_OBJS)
-AC_SUBST(WINBIND_NSS_EXTRA_LIBS)
-
# Check the setting of --with-winbindd
AC_ARG_WITH(winbind,
@@ -3046,22 +3033,37 @@ fi
# Display test results
+WINBIND_TARGETS=""
+WINBIND_STARGETS=""
+WINBIND_LTARGETS=""
+WINBIND_PAM_PROGS=""
+
if test x"$HAVE_WINBIND" = x"yes"; then
AC_MSG_RESULT(yes)
AC_DEFINE(WITH_WINBIND,1,[Whether to build winbind])
- EXTRA_BIN_PROGS="$EXTRA_BIN_PROGS bin/wbinfo"
- EXTRA_SBIN_PROGS="$EXTRA_SBIN_PROGS bin/winbindd"
+ WINBIND_TARGETS="bin/wbinfo"
+ WINBIND_STARGETS="bin/winbindd"
if test x"$BLDSHARED" = x"true"; then
- SHLIB_PROGS="$SHLIB_PROGS nsswitch/libnss_winbind.so"
+ WINBIND_LTARGETS="nsswitch/libnss_winbind.so"
if test x"$with_pam" = x"yes"; then
- SHLIB_PROGS="$SHLIB_PROGS nsswitch/pam_winbind.so"
+ WINBIND_PAM_TARGETS="nsswitch/pam_winbind.so"
fi
fi
else
AC_MSG_RESULT(no$winbind_no_reason)
fi
+
+# Substitution time!
+
+AC_SUBST(WINBIND_TARGETS)
+AC_SUBST(WINBIND_STARGETS)
+AC_SUBST(WINBIND_LTARGETS)
+AC_SUBST(WINBIND_PAM_TARGETS)
+AC_SUBST(WINBIND_NSS_EXTRA_OBJS)
+AC_SUBST(WINBIND_NSS_EXTRA_LIBS)
+
# Solaris has some extra fields in struct passwd that need to be
# initialised otherwise nscd crashes. Unfortunately autoconf < 2.50
# doesn't have the AC_CHECK_MEMBER macro which would be handy for checking
@@ -3129,22 +3131,11 @@ AC_SUBST(FLAGS1)
# though they can coexist in different directories.) In the future
# this might make the Python stuff be built by default.
-# If you don't specify --with-python, we assume "python" anyhow,
-# because the extensions are not built until you specifically "make
-# python_ext". --without-python turns them off. Perhaps in the
-# future --with-python should make them automatically built by make
-# all.
-
-PYTHON=python
-
AC_ARG_WITH(python,
[ --with-python=PYTHONNAME build Python libraries],
[ case "${withval-python}" in
yes)
- EXTRA_ALL_TARGETS="$EXTRA_ALL_TARGETS python_ext"
- ;;
- no)
- PYTHON=
+ PYTHON=python
;;
*)
PYTHON=${withval-python}
@@ -3174,7 +3165,7 @@ AC_SUBST(builddir)
# I added make files that are outside /source directory.
# I know this is not a good solution, will work out a better
# solution soon. --simo
-AC_OUTPUT(include/stamp-h Makefile script/findsmb ../examples/sam/Makefile)
+AC_OUTPUT(include/stamp-h Makefile script/findsmb ../examples/VFS/Makefile)
#################################################
# Print very concise instructions on building/use