summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in27
1 files changed, 4 insertions, 23 deletions
diff --git a/source3/configure.in b/source3/configure.in
index fdc83769c7..167f977522 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2086,15 +2086,14 @@ fi
########################################################
# Compile with MySQL support?
-AM_PATH_MYSQL([0.11.0],[MODULE_PDB_MYSQL=bin/pdb_mysql.so],[MODULE_PDB_MYSQL=])
+AM_PATH_MYSQL()
CFLAGS="$CFLAGS $MYSQL_CFLAGS"
-AC_SUBST(MODULE_PDB_MYSQL)
+
########################################################
# Compile with XML support?
-AM_PATH_XML2([2.0.0],[MODULE_PDB_XML=bin/pdb_xml.so],[MODULE_PDB_XML=])
+AM_PATH_XML2()
CFLAGS="$CFLAGS $XML_CFLAGS"
-AC_SUBST(MODULE_PDB_XML)
#################################################
# check for automount support
@@ -2222,24 +2221,6 @@ if test x"$samba_cv_HAVE_TRUNCATED_SALT" = x"yes"; then
fi
fi
-# New experimental SAM system
-
-AC_MSG_CHECKING([whether to build the new (experimental) SAM database])
-AC_ARG_WITH(sam,
-[ --with-sam Build new (experimental) SAM database (default=no)],
-[ case "$withval" in
- yes)
- AC_MSG_RESULT(yes)
- AC_DEFINE(WITH_SAM,1,[Whether to build the new (experimental) SAM database])
- ;;
- *)
- AC_MSG_RESULT(no)
- ;;
- esac ],
- AC_MSG_RESULT(no)
-)
-
-
########################################################################################
##
## TESTS FOR SAM BACKENDS. KEEP THESE GROUPED TOGETHER
@@ -3176,7 +3157,7 @@ AC_SUBST(builddir)
# I added make files that are outside /source directory.
# I know this is not a good solution, will work out a better
# solution soon. --simo
-AC_OUTPUT(include/stamp-h Makefile script/findsmb ../examples/sam/Makefile)
+AC_OUTPUT(include/stamp-h Makefile script/findsmb ../examples/VFS/Makefile)
#################################################
# Print very concise instructions on building/use