summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in23
1 files changed, 17 insertions, 6 deletions
diff --git a/source3/configure.in b/source3/configure.in
index e700305283..9288f1cff5 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2572,14 +2572,23 @@ AC_MSG_CHECKING(whether to build winbind)
# Initially, the value of $host_os decides whether winbind is supported
-case "$host_os" in
- *linux*|*solaris*|*irix*)
+case "$host_os" in
+ *linux*|*irix*)
HAVE_WINBIND=yes
- ;;
- *)
+ ;;
+ *solaris*)
+ HAVE_WINBIND=yes
+ WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_solaris"
+ WINBIND_NSS_EXTGRA_LIBS="-lsocket"
+ ;;
+ *hpux11*)
+ HAVE_WINBIND=yes
+ WINBIND_NSS_EXTRA_OBJS="nsswitch/winbind_nss_solaris"
+ ;;
+ *)
HAVE_WINBIND=no
- winbind_no_reason=", unsupported on $host_os"
- ;;
+ winbind_no_reason=", unsupported on $host_os"
+ ;;
esac
# Check the setting of --with-winbindd
@@ -2635,6 +2644,8 @@ AC_SUBST(WINBIND_TARGETS)
AC_SUBST(WINBIND_STARGETS)
AC_SUBST(WINBIND_LTARGETS)
AC_SUBST(WINBIND_PAM_TARGETS)
+AC_SUBST(WINBIND_NSS_EXTRA_OBJS)
+AC_SUBST(WINBIND_NSS_EXTRA_LIBS)
#################################################
# Check to see if we should use the included popt