summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 07cf6e88cd..5221b8ec2b 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1961,11 +1961,11 @@ fi
AC_MSG_RESULT($with_ads_support)
+FOUND_KRB5=no
if test x"$with_ads_support" = x"yes"; then
#################################################
# check for location of Kerberos 5 install
-FOUND_KRB5=0
AC_MSG_CHECKING(for kerberos 5 install path)
AC_ARG_WITH(krb5,
[ --with-krb5=base-dir Locate Kerberos 5 support (default=/usr)],
@@ -1979,14 +1979,14 @@ FOUND_KRB5=0
CFLAGS="$CFLAGS -I$withval/include"
CPPFLAGS="$CPPFLAGS -I$withval/include"
LDFLAGS="$LDFLAGS -L$withval/lib"
- FOUND_KRB5=1
+ FOUND_KRB5=yes
;;
esac ],
AC_MSG_RESULT(no)
)
-if [ $FOUND_KRB5 = 0 ]; then
+if test x$FOUND_KRB5 = x"no"; then
#################################################
# see if this box has the RedHat location for kerberos
AC_MSG_CHECKING(for /usr/kerberos)
@@ -2168,7 +2168,7 @@ AC_ARG_WITH(pam_smbpass,
###############################################
# test for where we get crypt() from, but only
# if not using PAM
-if test $with_pam_for_crypt = no; then
+if test x"$with_pam_for_crypt" = x"no"; then
AC_CHECK_FUNCS(crypt)
if test x"$ac_cv_func_crypt" = x"no"; then
AC_CHECK_LIB(crypt, crypt, [LIBS="$LIBS -lcrypt";