summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in35
1 files changed, 33 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 52779ecff0..4d9b411cc4 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1748,15 +1748,27 @@ fi
fi
+
+########################################################################################
+##
+## TESTS FOR SAM BACKENDS. KEEP THESE GROUPED TOGETHER
+##
+########################################################################################
+
+## set the with_smbpasswd_sam as the default
+with_smbpasswd_sam=yes
+
+
#################################################
# check for a TDB password database
-AC_MSG_CHECKING(whether to use TDB password database)
+AC_MSG_CHECKING(whether to use TDB SAM database)
AC_ARG_WITH(tdbsam,
-[ --with-tdbsam Include experimental TDB password database (default=no)],
+[ --with-tdbsam Include experimental TDB SAM support (default=no)],
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)
AC_DEFINE(WITH_TDB_SAM)
+ with_smbpasswd_sam=no
;;
*)
AC_MSG_RESULT(no)
@@ -1801,6 +1813,25 @@ AC_ARG_WITH(nisplussam,
esac ],
AC_MSG_RESULT(no)
)
+
+################################################
+# This test should come last because the
+# smbpasswd SAM is only used if another format
+# has not been defined
+AC_MSG_CHECKING(whether to use traditional smbpasswd file)
+if test $with_smbpasswd_sam = yes; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_SMBPASSWD_SAM)
+else
+ AC_MSG_RESULT(no)
+fi
+
+########################################################################################
+##
+## END OF TESTS FOR SAM BACKENDS.
+##
+########################################################################################
+
#################################################
# check for a NISPLUS_HOME support
AC_MSG_CHECKING(whether to use NISPLUS_HOME)