summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/source3/configure.in b/source3/configure.in
index a6d078c8ce..3b940f08d9 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3389,13 +3389,13 @@ SMB_SUBSYSTEM(RPC)
SMB_MODULE(charset_weird, modules/developer.o, bin/developer.so, CHARSET)
SMB_SUBSYSTEM(CHARSET)
-SMB_MODULE(auth_rhosts, auth/auth_rhosts.o, bin/rhosts.so, AUTH)
-SMB_MODULE(auth_sam, auth/auth_sam.o, bin/sam.so, AUTH)
-SMB_MODULE(auth_unix, auth/auth_unix.o, bin/unix.so, AUTH)
-SMB_MODULE(auth_winbind, auth/auth_winbind.o, bin/winbind.so, AUTH)
-SMB_MODULE(auth_server, auth/auth_server.o, bin/server.so, AUTH)
-SMB_MODULE(auth_domain, auth/auth_domain.o, bin/domain.so, AUTH)
-SMB_MODULE(auth_builtin, auth/auth_builtin.o, bin/builtin.so, AUTH)
+SMB_MODULE(auth_rhosts, \$(AUTH_RHOSTS_OBJ), bin/rhosts.so, AUTH)
+SMB_MODULE(auth_sam, \$(AUTH_SAM_OBJ), bin/sam.so, AUTH)
+SMB_MODULE(auth_unix, \$(AUTH_UNIX_OBJ), bin/unix.so, AUTH)
+SMB_MODULE(auth_winbind, \$(AUTH_WINBIND_OBJ), bin/winbind.so, AUTH)
+SMB_MODULE(auth_server, \$(AUTH_SERVER_OBJ), bin/server.so, AUTH)
+SMB_MODULE(auth_domain, \$(AUTH_DOMAIN_OBJ), bin/domain.so, AUTH)
+SMB_MODULE(auth_builtin, \$(AUTH_BUILTIN_OBJ), bin/builtin.so, AUTH)
SMB_SUBSYSTEM(AUTH)
AC_DEFINE_UNQUOTED(STRING_STATIC_MODULES, "$string_static_modules", [String list of builtin modules])