summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in47
1 files changed, 47 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 9e4692b696..e424492716 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -322,6 +322,11 @@ AC_SUBST(UNINSTALL_LIBADDNS)
AC_SUBST(LIBADDNS_SHARED)
AC_SUBST(LIBADDNS)
+AC_SUBST(INSTALL_LIBTALLOC)
+AC_SUBST(UNINSTALL_LIBTALLOC)
+AC_SUBST(LIBTALLOC_SHARED)
+AC_SUBST(LIBTALLOC)
+
AC_SUBST(INSTALL_LIBWBCLIENT)
AC_SUBST(UNINSTALL_LIBWBCLIENT)
AC_SUBST(LIBWBCLIENT_SHARED)
@@ -5114,6 +5119,48 @@ if test $enable_static = yes; then
fi
#################################################
+# should we build libtalloc?
+INSTALL_LIBTALLOC=
+UNINSTALL_LIBTALLOC=
+LIBTALLOC_SHARED=
+LIBTALLOC=
+
+AC_MSG_CHECKING(whether to build the libtalloc shared library)
+AC_ARG_WITH(libtalloc,
+[AS_HELP_STRING([--with-libtalloc],
+ [Build the libtalloc shared library (default=yes if shared libs supported)])],
+[
+case "$withval" in
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ yes)
+ samba_cv_with_libtalloc=yes
+ ;;
+esac
+],
+[
+# if unspecified, default is to built it if possible.
+samba_cv_with_libtalloc=yes
+]
+)
+
+if test x"$samba_cv_with_libtalloc" = "xyes" -a $BLDSHARED = true; then
+ LIBTALLOC_SHARED=bin/libtalloc.$SHLIBEXT
+ LIBTALLOC=libtalloc
+ AC_MSG_RESULT(yes)
+else
+ enable_static=yes
+ AC_MSG_RESULT(no shared library support -- will supply static library)
+fi
+if test $enable_static = yes; then
+ LIBTALLOC=libtalloc
+fi
+INSTALL_LIBTALLOC=installlibtalloc
+UNINSTALL_LIBTALLOC=uninstalllibtalloc
+
+
+#################################################
# should we build libnetapi?
INSTALL_LIBNETAPI=
UNINSTALL_LIBNETAPI=