summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index d69a40eb90..b8e64e1ed7 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -169,6 +169,20 @@ AC_ARG_WITH(logfilebase,
;;
esac])
+
+#################################################
+# set ctdb source directory location
+AC_ARG_WITH(ctdb,
+[ --with-ctdb=DIR Where to find ctdb sources],
+[ case "$withval" in
+ yes|no)
+ AC_MSG_WARN([--with-ctdb called without argument])
+ ;;
+ * )
+ ctdbdir="$withval"
+ ;;
+ esac])
+
#################################################
# set lib directory location
AC_ARG_WITH(libdir,
@@ -254,6 +268,7 @@ AC_SUBST(configdir)
AC_SUBST(lockdir)
AC_SUBST(piddir)
AC_SUBST(logfilebase)
+AC_SUBST(ctdbdir)
AC_SUBST(privatedir)
AC_SUBST(swatdir)
AC_SUBST(bindir)