summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in22
1 files changed, 18 insertions, 4 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 805e8c0b06..c24a36b7db 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1512,12 +1512,19 @@ AC_MSG_CHECKING(whether to use Kerberos IV)
AC_ARG_WITH(krb4,
[ --with-krb4=base-dir Include Kerberos IV support
--without-krb4 Don't include Kerberos IV support (default)],
-[ AC_MSG_RESULT(yes)
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
AC_DEFINE(KRB4_AUTH)
AC_CHECK_LIB(resolv, dn_expand)
LIBS="$LIBS -lkrb -ldes"
CFLAGS="$CFLAGS -I$withval/include"
- LDFLAGS="$LDFLAGS -L$withval/lib"],
+ LDFLAGS="$LDFLAGS -L$withval/lib"
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
AC_MSG_RESULT(no)
)
@@ -1527,11 +1534,18 @@ AC_MSG_CHECKING(whether to use Kerberos 5)
AC_ARG_WITH(krb5,
[ --with-krb5=base-dir Include Kerberos 5 support
--without-krb5 Don't include Kerberos 5 support (default)],
-[ AC_MSG_RESULT(yes)
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
AC_DEFINE(KRB5_AUTH)
LIBS="$LIBS -ldes425 -lkrb5 -lcrypto -lcom_err"
CFLAGS="$CFLAGS -I$withval/include"
- LDFLAGS="$LDFLAGS -L$withval/lib"],
+ LDFLAGS="$LDFLAGS -L$withval/lib"
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
AC_MSG_RESULT(no)
)