summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 8ac3d20705..928e57baac 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -752,6 +752,18 @@ CPPFLAGS="$old_CPPFLAGS"
# subdirectory of headers.
AC_CHECK_HEADERS(valgrind.h valgrind/valgrind.h valgrind/memcheck.h)
+/* check for linux on amd64 since valgrind is not quite there yet */
+case "$host_os" in
+ *linux*)
+ case "$UNAME_P" in
+ *x86_64*)
+ AC_DEFINE(HAVE_64BIT_LINUX,1,[Whether we are running on 64bit linux])
+ ;;
+ esac
+ ;;
+esac
+
+
#
# HPUX has a bug in that including shadow.h causes a re-definition of MAXINT.
# This causes configure to fail to detect it. Check for shadow separately on HPUX.