summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in41
1 files changed, 26 insertions, 15 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 7eba74d710..2ad8b2d937 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1924,35 +1924,46 @@ if test "x$with_spinlocks" = "xyes"; then
fi
#################################################
-# check for POSIX ACL support
+# check for ACL support
-AC_MSG_CHECKING(whether to support POSIX ACLs)
-AC_ARG_WITH(posix-acls,
-[ --with-posix-acls Include POSIX ACL support
- --without-posix-acls Don't include POSIX ACL support (default)],
+AC_MSG_CHECKING(whether to support ACLs)
+AC_ARG_WITH(acl-support,
+[ --with-acl-support Include ACL support
+ --without-acl-support Don't include ACL support (default)],
[ case "$withval" in
yes)
- AC_CHECK_LIB(acl,acl_get_file)
-AC_CACHE_CHECK([for POSIX ACL support],samba_cv_HAVE_POSIX_ACLS,[
-AC_TRY_COMPILE([#include <sys/types.h>
+ case "$host_os" in
+ *unixware*)
+ AC_MSG_RESULT(Using SVR4 ACLs)
+ AC_DEFINE(HAVE_UNIXWARE_ACLS)
+ ;;
+ *solaris*)
+ AC_MSG_RESULT(Using solaris ACLs)
+ AC_DEFINE(HAVE_SOLARIS_ACLS)
+ ;;
+ *)
+ AC_CHECK_LIB(acl,acl_get_file)
+ AC_CACHE_CHECK([for ACL support],samba_cv_HAVE_POSIX_ACLS,[
+ AC_TRY_COMPILE([#include <sys/types.h>
#include <sys/acl.h>],
[ acl_t acl; int entry_id; acl_entry_t *entry_p; return acl_get_entry( acl, entry_id, entry_p);],
samba_cv_HAVE_POSIX_ACLS=yes,samba_cv_HAVE_POSIX_ACLS=no)])
-if test x"$samba_cv_HAVE_POSIX_ACLS" = x"yes"; then
- AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_POSIX_ACLS)
-fi
- ;;
+ if test x"$samba_cv_HAVE_POSIX_ACLS" = x"yes"; then
+ AC_MSG_RESULT(Using posix ACLs)
+ AC_DEFINE(HAVE_POSIX_ACLS)
+ fi
+ ;;
+ esac
+ ;;
*)
AC_MSG_RESULT(no)
AC_DEFINE(HAVE_NO_ACLS)
;;
esac ],
- AC_MSG_RESULT(no)
AC_DEFINE(HAVE_NO_ACLS)
+ AC_MSG_RESULT(no)
)
-
echo "checking configure summary"
AC_TRY_RUN([#include "${srcdir-.}/tests/summary.c"],
echo "configure OK";,