summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index cb26606a7c..a52b02fe87 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -762,6 +762,26 @@ AC_ARG_WITH(netatalk,
AC_MSG_RESULT(no)
)
+#################################################
+# check for experimental disk-quotas support
+QUOTAOBJS=noquotas.o
+
+AC_MSG_CHECKING(whether to support disk-quotas)
+AC_ARG_WITH(quotas,
+[ --with-quotas Include experimental disk-quota support
+ --without-quotas Don't include experimental disk-quota support (default)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ QUOTAOBJS=quotas.o
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+AC_SUBST(QUOTAOBJS)
#################################################
# these tests are taken from the GNU fileutils package