summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in9
1 files changed, 3 insertions, 6 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 53b95990b2..866380d3f7 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3135,18 +3135,15 @@ AC_SUBST(FLAGS1)
# though they can coexist in different directories.) In the future
# this might make the Python stuff be built by default.
-# If you don't specify --with-python, we assume "python" anyhow,
-# because the extensions are not built until you specifically "make
-# python_ext". --without-python turns them off. Perhaps in the
-# future --with-python should make them automatically built by make
-# all.
+# Defaulting python breaks the clean target if python isn't installed
-PYTHON=python
+PYTHON=
AC_ARG_WITH(python,
[ --with-python=PYTHONNAME build Python libraries],
[ case "${withval-python}" in
yes)
+ PYTHON=python
EXTRA_ALL_TARGETS="$EXTRA_ALL_TARGETS python_ext"
;;
no)