summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 9f1e9fe3c0..9f52cb7555 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1657,13 +1657,18 @@ AC_CHECK_LIB(k5crypto, krb5_encrypt_data, [LIBS="$LIBS -lk5crypto"])
AC_CHECK_LIB(krb5, krb5_mk_req_extended, [LIBS="$LIBS -lkrb5";
AC_DEFINE(HAVE_KRB5)])
+
+##################################################################
+# we might need the lber lib on some systems. To avoid link errors
+# this test must be before the libldap test
+AC_CHECK_LIB(lber, ber_scanf, [LIBS="$LIBS -llber"])
+
########################################################
# now see if we can find the ldap libs in standard paths
if test x$have_ldap != xyes; then
AC_CHECK_LIB(ldap, ldap_open, [LIBS="$LIBS -lldap";
AC_DEFINE(HAVE_LDAP)])
fi
-AC_CHECK_LIB(lber, ber_scanf, [LIBS="$LIBS -llber"])
#################################################