summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4ed1782301..cc71ccfc18 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -267,15 +267,6 @@ AC_SUBST(cachedir)
AC_SUBST(rootsbindir)
AC_SUBST(pammodulesdir)
-## check for --enable-debug first before checking CFLAGS before
-## so that we don't mix -O and -g
-debug=no
-AC_ARG_ENABLE(debug,
-[AS_HELP_STRING([--enable-debug], [Turn on compiler debugging information (default=no)])],
- [if eval "test x$enable_debug = xyes"; then
- debug=yes
- fi])
-
#################################################
# set prefix for 'make test'
selftest_prefix="./"
@@ -311,6 +302,15 @@ AC_ARG_WITH(smbtorture4_path,
esac
])
+## check for --enable-debug first before checking CFLAGS before
+## so that we don't mix -O and -g
+debug=no
+AC_ARG_ENABLE(debug,
+[AS_HELP_STRING([--enable-debug], [Turn on compiler debugging information (default=no)])],
+ [if eval "test x$enable_debug = xyes"; then
+ debug=yes
+ fi])
+
developer=no
AC_ARG_ENABLE(developer, [AS_HELP_STRING([--enable-developer], [Turn on developer warnings and debugging (default=no)])],
[if eval "test x$enable_developer = xyes"; then