summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 2e47cf2e64..4edd818e87 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2110,7 +2110,8 @@ if test "x$enable_external_libtalloc" = xno
then
m4_include(../lib/talloc/libtalloc.m4)
LINK_LIBTALLOC=STATIC
- SMB_LIBRARY(talloc, 2)
+ LIBTALLOCVERSION=`grep ^VERSION ${tallocdir}/wscript | sed -e "s/'//g" -e 's/.* //'`
+ SMB_LIBRARY(talloc, 2, ${LIBTALLOCVERSION})
LIBTALLOC_OBJ0=""
for obj in ${TALLOC_OBJ}; do
LIBTALLOC_OBJ0="${LIBTALLOC_OBJ0} ${tallocdir}/${obj}"