summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 3716299d9e..04baf8aafb 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -338,6 +338,21 @@ AC_LIBREPLACE_CC_CHECKS
m4_include(lib/socket_wrapper/config.m4)
+
+AC_ARG_ENABLE(swat,
+[ --enable-swat Build the SWAT tool (default=yes)],
+[
+ case "$enable_swat" in
+ no) ;;
+ *)
+ SWAT_SBIN_TARGETS='bin/swat$(EXEEXT)'
+ SWAT_INSTALL_TARGETS=installswat
+ ;;
+ esac
+ AC_SUBST(SWAT_SBIN_TARGETS)
+ AC_SUBST(SWAT_INSTALL_TARGETS)
+])
+
#################################################
# set prefix for 'make test'
selftest_prefix="./"