summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index eacbe6a466..5e5d550555 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3478,6 +3478,14 @@ if test x"$with_ldap_support" != x"no"; then
AC_CHECK_LIB_EXT(lber, LDAP_LIBS, ber_scanf)
########################################################
+ # If ber_sockbuf_add_io() is available we can add
+ # SASL wrapping hooks
+ AC_CHECK_FUNC_EXT(ber_sockbuf_add_io,$LDAP_LIBS)
+ if test x"$ac_cv_func_ext_ber_sockbuf_add_io" = x"yes"; then
+ AC_DEFINE(HAVE_ADS_SASL_WRAPPING, 1, [Support for SASL wrapping])
+ fi
+
+ ########################################################
# now see if we can find the ldap libs in standard paths
AC_CHECK_LIB_EXT(ldap, LDAP_LIBS, ldap_init)