summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 46b82af4b2..2340a1129c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -782,7 +782,7 @@ AC_CACHE_CHECK([whether building shared libraries actually works],
ac_cv_shlib_works=no
# try building a trivial shared library
$CC $CPPFLAGS $CFLAGS $PICFLAG -c -o shlib.po ${srcdir-.}/tests/shlib.c &&
- $CC $LDSHFLAGS -o shlib.so shlib.po &&
+ $CC $CPPFLAGS $CFLAGS $LDSHFLAGS -o shlib.so shlib.po &&
ac_cv_shlib_works=yes
rm -f shlib.so shlib.po
])
@@ -2538,7 +2538,7 @@ fi
# Display test results
-if test x"$HAVE_WINBIND" = x"yes"; then
+if test x"$HAVE_WINBIND" = x"yes" && test x"$BLDSHARED" = x"true"; then
AC_MSG_RESULT(yes)