summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index db524d5891..02904800a3 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -4586,6 +4586,29 @@ if test x"${try_pam}" != x"no";then
AC_MSG_CHECKING(whether to have PAM MODULES support)
AC_MSG_RESULT([$create_pam_modules])
+
+ AC_TRY_COMPILE([
+ #if defined(HAVE_SECURITY_PAM_APPL_H)
+ #include <security/pam_appl.h>
+ #elif defined(HAVE_PAM_PAM_APPL_H)
+ #include <pam/pam_appl.h>
+ #endif],[
+ pam_set_item(0, PAM_RHOST, 0);
+ ],
+ AC_DEFINE(HAVE_PAM_RHOST, 1,
+ [Define to 1 if PAM_RHOST is available]),[])
+
+ AC_TRY_COMPILE([
+ #if defined(HAVE_SECURITY_PAM_APPL_H)
+ #include <security/pam_appl.h>
+ #elif defined(HAVE_PAM_PAM_APPL_H)
+ #include <pam/pam_appl.h>
+ #endif],[
+ pam_set_item(0, PAM_TTY, 0);
+ ],
+ AC_DEFINE(HAVE_PAM_TTY, 1,
+ [Define to 1 if PAM_TTY is available]),[])
+
fi # try_pam != no
#################################################