summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in16
1 files changed, 11 insertions, 5 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 26ec10ba5c..9a190cc872 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2644,18 +2644,19 @@ if test x$enable_fam != xno; then
# On IRIX, libfam requires libC, but other FAM implementations
# might not need it.
AC_CHECK_LIB(fam, FAMOpen2,
- [samba_cv_HAVE_LIBFAM=yes; SMB_FAM_LIBS="-lfam"],
- [samba_cv_HAVE_LIBFAM=no])
+ [samba_cv_HAVE_LIBFAM=yes; SMB_FAM_LIBS="-lfam";
+ AC_DEFINE(HAVE_FAMOPEN2, 1, Define to 1 if there is support for FAMOpen2)],
+ [samba_cv_HAVE_LIBFAM=no])
if test x"$samba_cv_HAVE_LIBFAM" = x"no" ; then
samba_fam_xtra=-lC
AC_CHECK_LIB_EXT(fam, samba_fam_xtra, FAMOpen2,
- [samba_cv_HAVE_LIBFAM=yes; SMB_FAM_LIBS="-lfam -lC"],
- [samba_cv_HAVE_LIBFAM=no])
+ [samba_cv_HAVE_LIBFAM=yes; SMB_FAM_LIBS="-lfam -lC";
+ AC_DEFINE(HAVE_FAMOPEN2, 1, Define to 1 if there is support for FAMOpen2)],
+ [samba_cv_HAVE_LIBFAM=no])
unset samba_fam_xtra
fi
fi
-
if test x"$samba_cv_HAVE_LIBFAM" = x"yes" ; then
default_shared_modules="$default_shared_modules vfs_notify_fam"
AC_TRY_COMPILE([#include <fam.h>],
@@ -2665,6 +2666,11 @@ if test x$enable_fam != xno; then
[])
fi
+ if test x"$samba_cv_HAVE_LIBFAM" = x"yes" ; then
+ AC_CHECK_LIB(fam, FAMNoExists,
+ [AC_DEFINE(HAVE_FAMNOEXISTS, 1, Define to 1 if there is support for FAMNoExists)])
+ fi
+
if test x$enable_fam = xyes && test x"$samba_cv_HAVE_LIBFAM" != xyes ; then
AC_MSG_ERROR(FAM support requested but FAM library not available )
fi